我爱秘籍论坛

 找回密码
 加入论坛

QQ登录

只需一步,快速开始

扫一扫,访问微社区

CE:最优秀的游戏修改工具入门:修改器制作傻瓜教程说说:你最想要找的修改器以前游戏玩我们,现在我们玩游戏
进阶:游戏修改视频教程导航必备:超2400款游戏秘籍下载:超5000款游戏修改器必读:论坛金币获得方法
查看: 3408|回复: 7

[其它] 植物大战僵尸易语言制作无限太阳写法

[复制链接]
发表于 2011-7-20 00:00:09 | 显示全部楼层 |阅读模式
.版本 2
.程序集 窗口程序集1
.程序集变量 ID, 整数型
.程序集变量 地址1, 整数型
.程序集变量 地址2, 整数型
.程序集变量 星星地址, 整数型
.程序集变量 nn, 整数型
.子程序 _时钟1_周期事件
ID = 进程取ID (“PlantsVsZombies.exe”)
地址1 = 读内存整数型 (ID, 十六到十 (#基址))
地址2 = 读内存整数型 (ID, 地址1 + 十六到十 (“768”))
星星地址 = 读内存整数型 (ID, 地址2 + 十六到十 (“5560”))
' 星星地址 = 读内存整数型 (ID, 十六到十 (#基址) + 十六到十 (“768”) + 十六到十 (“5560”))
标签1.标题 = 到文本 (星星地址)
写内存整数型 (ID, 地址2 + 十六到十 (“5560”), 99999)

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?加入论坛

x
发表于 2011-7-20 01:10:21 | 显示全部楼层
这个不是 无限 ,最起码要有个时钟。时钟周期=1
发表于 2011-7-20 08:06:51 | 显示全部楼层
回复 2# 154251406


    你的回答很无聊,时钟我最讨厌了,还有为什么非要是1毫秒 T_T
   笨蛋
发表于 2011-7-20 08:24:06 | 显示全部楼层
都是模块党~无语
发表于 2011-7-20 10:21:33 | 显示全部楼层
看不懂
发表于 2011-7-20 10:40:05 | 显示全部楼层
用读游戏内存整数型 更方便些
发表于 2012-3-10 15:23:39 | 显示全部楼层
154251406 发表于 2011-7-20 01:10
这个不是 无限 ,最起码要有个时钟。时钟周期=1

对,要设置时钟
回复 支持 反对

使用道具 举报

头像被屏蔽
发表于 2018-1-15 11:47:50 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入论坛

本版积分规则

QQ|Archiver|手机版|小黑屋|我爱秘籍论坛  

GMT+8, 2020-2-22 18:06 , Processed in 0.109880 second(s), 29 queries , Gzip On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表